zEvolutions
[Question] Fehlermeldung nach Installation - Druckversion

+- zEvolutions (http://www.zevolutions.de)
+-- Forum: Community Content (http://www.zevolutions.de/forumdisplay.php?fid=14)
+--- Forum: Bugreport (http://www.zevolutions.de/forumdisplay.php?fid=11)
+--- Thema: [Question] Fehlermeldung nach Installation (/showthread.php?tid=355)

Seiten: 1 2


Fehlermeldung nach Installation - HeikoH - 11.11.2015

URL zu deinem ZE-Projekt: http://www.julia-palmer-stoll.de/chatroom

Deine ZE-Version: 0.9

Deine PHP-Version: 5.2 bis 5.6

Deine MySQL-Version: 5.5

Fehler- oder Problembeschreibung:
Ich habe gerade Euren Chat entdeckt und die Demoversion gefiel mir sehr gut. Also habe ich mir Eure Chatsoftware mal heruntergeladen und wollte sie gerade testen. Installation war auch relativ einfach bis auf eine Stelle, an der ich bei der Installation nicht so genau wusste was dort einzutragen ist, einfach weil es dort keine Feldbezeichner gibt (siehe Bild). Ansonsten verlief die Installation ohne Probleme oder Fehler. Wenn ich nun aber nach der Installation die Startseite aufrufen möchte, erhalte ich nur die folgende Fehlermeldung:

Parse error: syntax error, unexpected T_FUNCTION in /var/www/web58/html/julia-palmer-stoll/chatroom/class/roomSelection.class.php on line 337

Zu genau dieser Fehlermeldung habe ich hier auch bereits einen Thread gefunden, jedoch leider ohne eine Lösung des Problems.

Was hast du bereits versucht um den Fehler/das Problem zu lösen:
Ich habe mich hier im Forum nach einer Lösung umgesehen, konnte aber bisher nichts finden, was mir weiter geholfen hätte. Ansonsten habe ich noch nichts weiter unternommen, da ich im Moment einfach ratlos bin.


RE: Fehlermeldung nach Installation - Hajo1 - 11.11.2015

(11.11.2015, 15:29)Hallo Heiko,wenn Du bei diesem Fenster alles Blau Markierst mit der Maustaste werden die Sachen Sichtbar was Du eintragen mußt.Leider ist es wohl weiße Schrift auf weißem Grund.Aber so hat es bei mir auch geklappt.Wünsche noch einen schönen Tag. HeikoH schrieb: URL zu deinem ZE-Projekt: http://www.julia-palmer-stoll.de/chatroom

Deine ZE-Version: 0.9

Deine PHP-Version: 5.2 bis 5.6

Deine MySQL-Version: 5.5

Fehler- oder Problembeschreibung:
Ich habe gerade Euren Chat entdeckt und die Demoversion gefiel mir sehr gut. Also habe ich mir Eure Chatsoftware mal heruntergeladen und wollte sie gerade testen. Installation war auch relativ einfach bis auf eine Stelle, an der ich bei der Installation nicht so genau wusste was dort einzutragen ist, einfach weil es dort keine Feldbezeichner gibt (siehe Bild). Ansonsten verlief die Installation ohne Probleme oder Fehler. Wenn ich nun aber nach der Installation die Startseite aufrufen möchte, erhalte ich nur die folgende Fehlermeldung:

Parse error: syntax error, unexpected T_FUNCTION in /var/www/web58/html/julia-palmer-stoll/chatroom/class/roomSelection.class.php on line 337

Zu genau dieser Fehlermeldung habe ich hier auch bereits einen Thread gefunden, jedoch leider ohne eine Lösung des Problems.

Was hast du bereits versucht um den Fehler/das Problem zu lösen:
Ich habe mich hier im Forum nach einer Lösung umgesehen, konnte aber bisher nichts finden, was mir weiter geholfen hätte. Ansonsten habe ich noch nichts weiter unternommen, da ich im Moment einfach ratlos bin.



RE: Fehlermeldung nach Installation - Zion - 11.11.2015

Das mit dem Installer ist bekannt, ja. Da einfach den unsichtbaren Text markieren und es sollte alles lesbar sein.

Bzgl deiner Fehlermeldung: welche PHP Version denn nun genau? Die funktion erwartet eine bestimmte Version. (Am besten mal dazu die Suche benutzen, da das Thema schon ein paar mal aufkam)

EDIT:

Alternativ kannst du natürlich den 0.9er gleich auf die 1.0 updaten und schauen, ob die Fehlermeldung damit Geschichte ist.

=> http://www.zevolutions.de/showthread.php?tid=306


RE: Fehlermeldung nach Installation - Pat on Tour - 11.11.2015

noch ne alternative wäre den fertigen 1.0 von mir, hier zu finden http://www.zevolutions.de/showthread.php?tid=313


RE: Fehlermeldung nach Installation - HeikoH - 11.11.2015

Erstmal vielen lieben Dank für Eure Antworten!
Also zur PHP-Version: ich habe einfach in die Serverdaten von meinem Provider (Alfahosting) geschaut und dort steht angegeben PHP-Version: 4.4, 5.2 bis 5.6 Ich kenne mich mit diesen Dingen nun nicht so besonders gut aus, aber ich nehme mal an, dass die Versionen 5.2 bis 5.6 unterstützt werden.

Die Sache mit dem Update auf 1.0 habe ich gerade versucht, erhalte aber nach der Ausführung der Update10.php nur die folgenden Fehlermeldungen:

Warning: Invalid argument supplied for foreach() in /var/www/web58/html/julia-palmer-stoll/chatroom/update10.php on line 42

Warning: Invalid argument supplied for foreach() in /var/www/web58/html/julia-palmer-stoll/chatroom/update10.php on line 42

Warning: Invalid argument supplied for foreach() in /var/www/web58/html/julia-palmer-stoll/chatroom/update10.php on line 42
Done! Show Chat
Please delete this file!


RE: Fehlermeldung nach Installation - Zion - 11.11.2015

Dann wirst du vermutlich mit einer alten PHP Version haben, irgendwo aber die Möglichkeit besitzen, auf eine aktuellere Version zu upgraden.


RE: Fehlermeldung nach Installation - HeikoH - 12.11.2015

So, ich habe mir das mit der PHP-Version jetzt nochmal angesehen und die Einstellungen dafür gefunden. Dort war als verwendete Version 5.2 eingestellt und ich habe das jetzt auf 5.3 geändert, da ich hier irgendwo gelesen habe, dass mindestens 5.3 vorausgesetzt wird. Dann habe ich das ganze Chat-Script noch einmal vom Server gelöscht und auch die Datenbank noch einmal gelöscht und neu erstellt. Dann das Chat-Script wieder neu auf den Server geladen und Installation durchgeführt. Diesmal habe ich mir auch die Feldnamen alle sichtbar gemacht und konnte somit die Felder alle korrekt ausfüllen. Als ich die Installation dann abgeschlossen hatte und die Chat Startseite aufgerufen werden sollte (geht ja automatisch), bekam ich wieder nur die Fehlermeldung aus meinem Eröffnungsposting.

Ich weiß nun wirklich nicht mehr, was ich noch versuchen soll...


RE: Fehlermeldung nach Installation - Zion - 12.11.2015

Sei doch bitte so gut, und geh nicht von den MINDESTanforderungen aus (die veraltet sind), sondern nimm das aktuellste, was du zur Verfügung hast...


RE: Fehlermeldung nach Installation - HeikoH - 13.11.2015

OK, habe ich jetzt gemacht, PHP-Version ist jetzt bei mir 5.6.
Wieder alles gelöscht und nochmal neu installiert und wieder dieselbe Fehlermeldung wie aus dem ersten Beitrag. Also irgendetwas stimmt da wohl mit Eurer Chatsoftware nicht, lässt sich bei mir einfach nicht installieren.


RE: Fehlermeldung nach Installation - Zion - 13.11.2015

Deshalb läuft es ja auch bei 99,9% aller anderen Wink Die Software hat einen Fehler...


Sei es drum. Überprüfe nochmal genau, ob du die aktuelle PHP Version benutzt.

Dazu erstellst du dir eine Datei im selben Verzeichnis, in dem du den Chat installiert hast mit folgendem Inhalt:

PHP-Code:
<?php phpinfo(); ?>

und rufst diese im Anschluss in deinem Browser auf. Dort wird dir genau gesagt, mit welcher PHP Version diese Datei nun tatsächlich arbeitet.

Besagte Zeile würde einzig nicht funktionieren, wenn die PHP Version unter 5.3 liegt.